[PLUG] zte mc315 pcmcia card

Ashutosh Chauhan ashutosh.chauhan at gmail.com
Sat Aug 4 19:33:59 IST 2007

Dear all,

Yeps, its another one of those. I cant get *some device* working on
linux, can you help. :)

I purchased zte mc315 from reliance last year and still struggling to make
it work in linux. I searched on plug and other lug lists but could not find
any reported success in making this chinese marvel of engineering to work.
But, problem seems to be rather fundamental. Here is the post by the
prof who teaches in reliance's engineering college at ahemdabad pointing
out the problems in kernel itself
http://lists.infradead.org/pipermail/linux-pcmcia/2006-November/004114.html to
which Russell King (one of the maintainer of kernel) replied:

It seems problem cant be solved after reading that thread, but wait its
still not the end, starting may 07 some people has reported success
http://jayant7k.blogspot.com/2007/05/installing-zte-mc315-on-linux.html and
here http://www.rimweb.in/forums/lofiversion/index.php/t9409.html .

As for me this chinese marvel is behaving rather strangely. I followed the
instructions there. When I do dmesg | grep tty it says pcmcia card detected
at ttyS0, then i run setserial. When i run wvdialconf (which is suppose to
generate default conf file), it fails and says no modem is detected. Then
i went forward and manually created wvdial.conf as indicated in those
postings. Then all the madness follows: randomly (meaning i cant predict
when) wvdial is successful and starts pppd but then ppd fails and exits with
error code : 19 saying authentication errror. It happens about 1/10 and at
other times wvdial itself fails saying "modem is not responding".

I think the way to go about it is to figure out why wvdial is not able to
detect the modem, fix it and then move on, but i have no idea how to do it.

Any pointers? I am on Fedora Core 5.


More information about the Plug-mail mailing list