[PLUG] Fedora doesnt boot

abhi abhi.elementx at gmail.com
Thu Nov 12 14:11:14 IST 2009

hi all.
My fedora (and Win Xp) refuses to boot.I have a dual boot system(5 fedora 11
kernels + Win Xp)
The previous night, my system was updating kernel and hung. So, i stopped
Next morning when i tried to boot, i cud see the progress bar, but after
that a small cursor wud blink and just sit there.
*None of the kernels wud start*. So i went to rescue mode(using the DVD) and
did this
>chroot /mnt/sysimage
>grub-install --recheck /dev/sda

Now i have a single hard drive(160 GB) with multiple partitions.
/dev/sdb1 -> some XP hidden partition
/dev/sdb2 -> my C drive
/dev/sdb3 -> my D drive
/dev/sdb4 -> root of fedora
So when i ran this command, it said 'No BIOS drive found'(or something like
This screwed up everything. I cudnt see the GRUB anymore.
So i went to the rescue mode again and did this:
>grub-install --recheck /dev/sdb2

This time, however, it successfully did something with no errors returned
and the GRUB came back. But now, i was facing the initial problem(issue with
kernel bootup) plus another one - *selecting Win XP would start Fedora*.

I can however goto the shell by pressing  ALT + F2/F3.

Thank you.

More information about the Plug-mail mailing list