[PLUG] Error in login as a LDAP user-More detailed step by step

Mandar Vaze / मंदार वझे mandarvaze at gmail.com
Wed Jun 2 21:31:21 PDT 2010


> Preparing LDAP database...
> Migration failed: saving failed LDIF to /tmp/nis.3257.ldif
> ---------------------------------------------------------------------
>
>
>
> The contents of /root/migrerr {This file contains errors of the
> script.}are:
>
> -------------------------------------------------------------------------------------
> slapadd: line 5: database (dc=example,dc=com) not configured to hold
> "dc=padl,dc=com"
> slapadd: line 5: database (dc=example,dc=com) not configured to hold
> "dc=padl,dc=com"
>
> -------------------------------------------------------------------------------------
>
>

> On both server & client machine;
> 4.  Output of the command-> ldapsearch -x -b 'dc=example,dc=com'
>  '(objectclass=*)'
>
>
> # extended LDIF
> #
> # LDAPv3
> # base <dc=example,dc=com> with scope subtree
> # filter: (objectclass=*)
> # requesting: ALL
> #
>
> # search result
> search: 2
> result: 32 No such object
>
> # numResponses: 1
>


I don't think LDAP is set correctly. Why the conflict between example.comand
padl.com ?
(Troubleshooting LDAP installation may be out of the scope on this thread)

chown is only one of the problems. You need to be able to successfully run
ldapsearch before trying anything else.
BTW, what does your nsswitch.conf look like ? does it have entry for ldap
for passwd and groups ?

-Mandar


More information about the plug-mail mailing list