[PLUG] unable to build GraphicsMagick from src rpm

Agnello George agnello.dsouza at gmail.com
Tue Nov 16 23:41:26 PST 2010


Hi

I am trying to build GraphicsMagick  from source rpm (
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/linux/GraphicsMagick-1.3.12-1.src.rpm
) , how ever i am getting the below errors  . I cant figure what is
required here .


[root at linux-app ~]# rpm -qa |grep rpm
rpm-libs-4.4.2.3-20.el5_5.1
redhat-rpm-config-8.0.45-32.el5.centos
rpm-libs-4.4.2.3-20.el5_5.1
rpmforge-release-0.3.6-1.el5.rf
rpm-python-4.4.2.3-20.el5_5.1
rpm-devel-4.4.2.3-20.el5_5.1
rpm-devel-4.4.2.3-20.el5_5.1
rpm-build-4.4.2.3-20.el5_5.1
rpm-4.4.2.3-20.el5_5.1



rpmbuild -bb GraphicsMagick-1.3.12-1.src.rpm


:
:
g-devel libtiff-devel libxml2-devel zlib-devel

Processing files: GraphicsMagick-debuginfo-1.3.9-1
Provides: analyze.so.debug()(64bit) art.so.debug()(64bit)
avi.so.debug()(64bit) avs.so.debug()(64bit) bmp.so.debug()(64bit)
cals.so.debug()(64bit) caption.so.debug()(64bit)
cineon.so.debug()(64bit) cmyk.so.debug()(64bit) cut.so.debug()(64bit)
dcm.so.debug()(64bit) dcraw.so.debug()(64bit) dib.so.debug()(64bit)
dpx.so.debug()(64bit) ept.so.debug()(64bit) fax.so.debug()(64bit)
fits.so.debug()(64bit) gif.so.debug()(64bit)
gradient.so.debug()(64bit) gray.so.debug()(64bit)
histogram.so.debug()(64bit) hrz.so.debug()(64bit)
html.so.debug()(64bit) icon.so.debug()(64bit)
identity.so.debug()(64bit) jpeg.so.debug()(64bit)
label.so.debug()(64bit) libGraphicsMagick++.so.3.3.0.debug()(64bit)
libGraphicsMagick.so.3.4.0.debug()(64bit)
libGraphicsMagickWand.so.2.2.0.debug()(64bit) locale.so.debug()(64bit)
logo.so.debug()(64bit) map.so.debug()(64bit) mat.so.debug()(64bit)
matte.so.debug()(64bit) meta.so.debug()(64bit) miff.so.debug()(64bit)
mono.so.debug()(64bit) mpc.so.debug()(64bit) mpeg.so.debug()(64bit)
mpr.so.debug()(64bit) msl.so.debug()(64bit) mtv.so.debug()(64bit)
mvg.so.debug()(64bit) null.so.debug()(64bit) otb.so.debug()(64bit)
palm.so.debug()(64bit) pcd.so.debug()(64bit) pcl.so.debug()(64bit)
pcx.so.debug()(64bit) pdb.so.debug()(64bit) pdf.so.debug()(64bit)
pict.so.debug()(64bit) pix.so.debug()(64bit) plasma.so.debug()(64bit)
png.so.debug()(64bit) pnm.so.debug()(64bit) preview.so.debug()(64bit)
ps.so.debug()(64bit) ps2.so.debug()(64bit) ps3.so.debug()(64bit)
psd.so.debug()(64bit) pwp.so.debug()(64bit) rgb.so.debug()(64bit)
rla.so.debug()(64bit) rle.so.debug()(64bit) sct.so.debug()(64bit)
sfw.so.debug()(64bit) sgi.so.debug()(64bit) stegano.so.debug()(64bit)
sun.so.debug()(64bit) svg.so.debug()(64bit) tga.so.debug()(64bit)
tiff.so.debug()(64bit) tile.so.debug()(64bit) tim.so.debug()(64bit)
topol.so.debug()(64bit) ttf.so.debug()(64bit) txt.so.debug()(64bit)
uil.so.debug()(64bit) url.so.debug()(64bit) uyvy.so.debug()(64bit)
vicar.so.debug()(64bit) vid.so.debug()(64bit) viff.so.debug()(64bit)
wbmp.so.debug()(64bit) wmf.so.debug()(64bit) wpg.so.debug()(64bit)
x.so.debug()(64bit) xbm.so.debug()(64bit) xc.so.debug()(64bit)
xcf.so.debug()(64bit) xpm.so.debug()(64bit) xwd.so.debug()(64bit)
yuv.so.debug()(64bit)
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/GraphicsMagick-1.3.9-root


RPM build errors:
    File not found by glob:
/var/tmp/GraphicsMagick-1.3.9-root/usr/lib64/perl*/site_perl/*/*/Graphics
    File not found by glob:
/var/tmp/GraphicsMagick-1.3.9-root/usr/lib64/perl*/site_perl/*/*/Graphics/Magick.pm
    File not found by glob:
/var/tmp/GraphicsMagick-1.3.9-root/usr/lib64/perl*/site_perl/*/*/auto/Graphics/Magick
    File not found by glob:
/var/tmp/GraphicsMagick-1.3.9-root/usr/lib64/perl*/site_perl/*/*/auto/Graphics/Magick/*
    File not found by glob:
/var/tmp/GraphicsMagick-1.3.9-root/usr/share/man/man3/*gz


Does any one have a idea what i am missing here !!

Thanks


-- 
Regards
Agnello D'souza



More information about the plug-mail mailing list