[PLUG] Building kernel module RPM for all kernel version in RHEL 6

Sankarshan Mukhopadhyay sankarshan.mukhopadhyay at gmail.com
Sun Mar 9 21:55:02 PDT 2014


On Fri, Mar 7, 2014 at 7:40 PM, Abhijeet Kasurde
<abhijeetkasurde21 at gmail.com> wrote:
> I have created a RPM-spec file for kernel 2.6.32-358 (RHEL 6.4), and
> it gives me working RPM. Now here is problem, when I install that same
> RPM on kernel 2.6.32-279 (RHEL 6.3), modprobe fails as .ko file goes
> in /lib/modules/2.6.32-358.el6-x86_64/extra.

A reasonably clean way is to compile your kernel module for each new
version of the kernel that you want to work with. Would it be possible
for you to explain a bit more about why you do not want to take that
route?


-- 
sankarshan mukhopadhyay
<https://twitter.com/#!/sankarshan>



More information about the plug-mail mailing list