[PLUG] Got Tata Indicom Broadband working on Linux (FC5)

Nishit Dave stargazer.dave at gmail.com
Fri Dec 1 06:39:33 IST 2006

After months of agony, I have found a simple solution.  Using rp-pppoe
2.4.3 on FC5, I am now able to use Tata Indicom Broadband through a
lan cable to eth0.

The trick lay in deleting all entries from /etc/ppp/chap-secrets,
/etc/ppp/pap-secrets, /etc/ppp/options and /etc/ppp/resolv.conf.
Then, as root, I ran the /etc/sbin/ppoe-setup script again, gave all
the correct parameters (including the two DNS server addersses).

The /etc/sbin/pppoe-start script then connected at first attempt.  I
had pirut running overnight, and in the early morning the connection
was creeping.

/etc/sbin/pppoe-stop as root closed the connection, and the
pppoe-start script connected again on second attempt after one time
out.  Pirut didn't drop the process in the mean time.

There, the experimental results have been reproduced.  All in all, if
the Tata Indicom personnel gave the same level of support to Linux as
Windows, i.e. "clear your cache and delete all cookies, double click
on the dialer shortcut" on the above lines, the problem would have
been solved earlier.

More information about the Plug-mail mailing list