[PLUG] Re: Got Tata Indicom Broadband working on Linux (FC5)

Nishit Dave stargazer.dave at gmail.com
Fri Dec 1 22:40:03 IST 2006

On 12/1/06, Nishit Dave <stargazer.dave at gmail.com> wrote:
> After months of agony, I have found a simple solution.  Using rp-pppoe
> 2.4.3 on FC5, I am now able to use Tata Indicom Broadband through a
> lan cable to eth0.
> The trick lay in deleting all entries from /etc/ppp/chap-secrets,
> /etc/ppp/pap-secrets, /etc/ppp/options and /etc/ppp/resolv.conf.
> Then, as root, I ran the /etc/sbin/ppoe-setup script again, gave all
> the correct parameters (including the two DNS server addersses).
> The /etc/sbin/pppoe-start script then connected at first attempt.  I
> had pirut running overnight, and in the early morning the connection
> was creeping.
> /etc/sbin/pppoe-stop as root closed the connection, and the
> pppoe-start script connected again on second attempt after one time
> out.  Pirut didn't drop the process in the mean time.
> There, the experimental results have been reproduced.  All in all, if
> the Tata Indicom personnel gave the same level of support to Linux as
> Windows, i.e. "clear your cache and delete all cookies, double click
> on the dialer shortcut" on the above lines, the problem would have
> been solved earlier.

Follow up: Later reconnections failed.  It seems the earlier post
(April 2006) by Mayuresh on this topic was accurate.  There is no
empirical measure of when connections will be successful.  The hack is
to increase timeout settings in /etc/ppp/pppoe.conf to say 300 secs
from 30 secs.  It will eventually succeed in getting you a working
connection after n attempts.

Better than no connection, I should say.  By the way, can anybody tell
me what happens to updates already downloaded through Pirut, if the
connection fails midway?

More information about the Plug-mail mailing list