[PLUG] Firefox, yum cannot resolve URLs in Fedora Core 6

Nishit Dave stargazer.dave at gmail.com
Thu Mar 1 17:15:55 IST 2007

I use a BSNL Dataone connection with a Netgear DG632 router (currently on
router mode) that works fine with Windows XP.  Under FC6, Konqueror can use
the internet connection without a hitch, but firefox and yum (or yumex) and
perhaps other packages somehow do not detect the connection / do not use the
gateway - or something like that.

When I ping anything (say google.com) from the shell, it works perfectly.  I
tried the google.com ip address resolved through pinging in firefox, which
worked (and took me to www.google.co.in), but firefox did not resolve any of
the URLs within the same session.

I tried some googling for this problem, and came to a post that complained
about Fedora acting in this way, and mentioned that knoppix running even as
the live media version did not have this problem.  Well, I tried it too with
the latest knoppix live DVD, and it worked like a charm!  I don't know why
this is happening.  Does anybody have a solution short of switching from

I have the router connected to eth0, it assigns IP addresses to the clients
automatically through DHCP, and the client is also configured appropriately
(Knoppix, by the way, did not need any configuration).  It just worked (tm).

More information about the Plug-mail mailing list