[PLUG] Touchscreen working on HP tx1000 series tablet with Ubuntu 8.04 Hardy Heron amd64

Vishal Rao vishalrao at gmail.com
Sat May 10 21:25:00 IST 2008


Thought I would post my success trying to get the touchscreen working
on my tx1000 series HP Pavilion tx1302au tablet PC with Ubuntu Hardy
Heron 8.04 amd64 64-bit :-)

Searching for "touchscreen tx1000 linux" on Google gives a couple of
good links but I needed to do some more to get it to work:


The standard "evtouch" method almost worked but the calibration
setting was not good. Also the nvidia_new driver has the console
blanked out when I press CTRL+ALT+F1
so following the steps to calibrate means I had to either go back to
standard nv driver or an older nvidia driver...

I visited www.eeti.com.tw and went to the support page to download the
Linux driver but it is version 1.08.1227 at the moment.
The egalax_drv.so would not load in xorg with a "old version" error.

So I sent an email to the support contact email listed on the page and
an engineer replied quite quickly with an updated 64 bit driver file
version 2.02.1615.

Extracted this and followed the steps in the PDF guide to copy the
xorg module, add xorg.conf lines and run the TouchKit utility to
calibrate, and the touchscreen started working quite well!
I provided the device as usbauto which translated to /dev/usb/hiddev0
I believe... I have the Hardy built-in usbtouchscreen and usbhid
modules loaded as it is by default.

But I the taps to get the clicks was not working properly, tapping the
menus would not open them, tapping the trash can icon would open 2
windows, that was a clue.
What was happening is the menus were getting 2 taps so it would open
and close quickly appearing not to work.

So I disabled (commented out) the "mouse" device lines in xorg.conf,
still the same problem.

Then when I added the line [Option "CorePointer"] to the egalax device
section (without the brackets of course) and restarted Xorg, the taps
were giving proper clicks!

Now the touchscreen is working nicely for me :-)

If you want the 64 bit driver file from me, please email me directly,
I'm not sure if it's redistributable right now.
For the 32 bit version, you can contact [touch_fae at eeti dot com]
and I will also email them to get the 32 bit file.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."

More information about the Plug-mail mailing list