[PLUG] Ubuntu 8.10 GRUB problem - only shows memtest option

Mandar Vaze mandarvaze at gmail.com
Fri Jan 16 23:46:12 IST 2009

On Fri, Jan 16, 2009 at 10:51 PM, Ulhas Bhole <bholeulhas at yahoo.com> wrote:

> Hi Mandar,
> I haven't followed the whole thread but if you are not keen on Windows
> loader to load Linux what you can do is change the boot flag. Currently you
> windows partion will have a boot flag active which you can change and mark
> your /dev/sda6 active (boot flag). you can do this by booting into Live
> CD/DVD and using gparted or if you are fan of commandline utility then you
> can use fdisk but it is bit risky there and you need to be sure about what
> you are doing with FDISK.

But logically, this seems like problem with installation itself, nothing to
do with Active parition.
I actually do get GRUB menu, and when selected it starts "memtest".
Problem is that there is no "vmlinuz" file at all on /boot (confirmed this
by mounting the file system via LiveCD)

If the "vmlinuz" file was present, Abhishek's suggestion of editing menu.lst
would have worked.

> Grub anyway should have your windows entry so you can use Grub to dual
> boot. To be honest I tried 2-3 times in past to configure windows boot
> loader to load Linux but failed all the time and gave up. Change active boot
> partition is much easier.

I have successfully tried it with PCQLinux (but with LILO, not GRUB) It is
not that complicated. But as I mentioned above, the files themselves are
missing from /boot, so LILO or GRUB may not matter.


More information about the Plug-mail mailing list