[PLUG] fdisk grub2 problem

Ranjit Bhonsle ranjya at gmail.com
Sun Jul 11 21:13:48 IST 2010

I had installed Ubuntu 10.04 on an extended partition using Live CD.
The Grub was installed on mbr.
Then I installed Mandriva 2010 and installed its grub on mbr.
I knew not that this grub and Ubuntu's grub are different.
Now I am unable to boot to Ubuntu inspite of adding it's entry to
Mandriva grub...I get the boot option but it does not boot.

So I tried to install the grub2 from Ubuntu to mbr
For this one has to mount and chroot where that partition is mounted.
But on doing
[ranjit at localhost ~]$ su
[root at localhost ranjit]# fdisk -l

Unable to seek on /dev/sda
[root at localhost ranjit]# sfdisk -l

Disk /dev/sda: 19457 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/sda1   *      0+   1304    1305-  10482381    7  HPFS/NTFS
/dev/sda2       1305+   5641    4337-  34836677    5  Extended
/dev/sda3          0       -       0          0    0  Empty
/dev/sda4          0       -       0          0    0  Empty
/dev/sda5       3407+   4622    1216-   9767488+   7  HPFS/NTFS
/dev/sda6       1305+   3250-   1946-  15625216   83  Linux
/dev/sda7       3250+   3406-    157-   1257472   82  Linux swap / Solaris
/dev/sda8       4623+   5641    1019-   8185086   83  Linux

what to do now? How to mount the device?
Even when I tried to reinstall Ubuntu using a DVD with Ultimate edition it
cannot read the partition table.
Any comments.

More information about the Plug-mail mailing list